2015年8月17日月曜日

Lenovo G560をWindows 10にアップデートした時のトラブルまとめ

Windows 10の無料アップデートプログラムが開始してから2週間と少しが経過しました。

私もVAIO SEと入れ替わる形で現役引退したLenovo G560をWindows 10にして遊んでいたのですが,結構洒落にならない不具合が多数あったため記事にまとめておこうと思います。



不具合
1.Google日本語入力がおかしい
2.対応していないオリジナルソフトやドライバがある
3.IE11が管理者権限でないと起動しない


特にIE11の件には思いっきり嵌まりました。




1.Google日本語入力がおかしい
多くのユーザーが同様の不具合を起こしているようで,一部の不具合はGoogle IMEの再インストールで解決します。

一度Google IME削除後,再インストールで正常になる不具合
IMEのアイコンが青いボールのようなものから「日本」の文字に変わってしまう,他アプリの挙動がおかしかったところ

正常にならない不具合
ユニバーサルアプリやタスクバーの検索ボックスなどで日本語入力ができない


一番の問題である入力不能問題が解決しません。
IME関係ではATOKも不具合が出ているようで,しばらくはMS-IMEを使うかWin+スペースキーで切り替えながら使うことになりそうです。



2.対応していないオリジナルソフトやドライバがある
Onekey RecoveryやEnergy Managementなど,そのままでは正常動作しないソフトが有ります。ちなみに,この2つは実行ファイルの互換設定を「Windows7互換」にすることで基本機能は問題なく動作します。(一部うまく動いていない機能も残る)
実行ファイルの格納されているフォルダを探し,関係しそうな実行ファイルすべての互換設定を変更するのがポイントです。

ただし,Elanのタッチパッドはうまく動きません。Windows Updateから最新のドライバが入りますが,それが上手く動かないのでどうしようもありません。
一応,デバイスマネージャからドライバの更新へ進み,一覧から選択でWindows標準のドライバを当てればエッジスクロールを含めた基本的な動作はします
Elanのドライバを削除してしまうと,またWindows Updateで自動的にインストールされてしまうので,削除せずに更新するところがポイントです。

また,Onekey Theatreという高画質ソフトも互換設定をしないと動きませんが,これに限ってはアンインストールするのが最善です。詳しくはIE11問題で。


3.IE11が管理者権限でないと起動しない
ひと通り実行ファイルの互換設定を終え,試験利用していたところ,IE11がアイコンを押しても起動しなくなっていました。
試しに管理者権限で実行すると起動します。

設定のリセットとかキャッシュのクリアとか出来そうなことは試したものの,効果なし。
仕方なくWindows 10をクリーンインストールすると正常動作しましたが,ドライバ類を入れていくとまたしても不具合再現。
G560オリジナルソフトが何かしら悪さをしているようなので,入れたり消したりいろいろ試しているうちに原因を突き止めました。


犯人はOnekey Theatre!


音量調整用のハードウェアキーと並んで専用キーが用意されており,そのキーをタッチすることで画質の調整ができるというアプリです。

折角ハードキーが用意されているということで使えるようにしていましたが,これがいけなかった。
ハードキーが1つ無駄になるのはすっきりしないものがありますが,元々TN液晶の廉価G560にとって高画質機能は重要ではないのでおとなしく削除してしまいます。

これでほぼ問題なく利用できるLenovo G560 Windows 10エディションが完成しました。

不具合は全機種共通のIME問題と,タッチパッドの設定が出来ないことと,1つ意味のないハードキーが出来てしまったことくらいです。




●おまけ
今回の一連の流れの中で,Windows 10のクリーンインストールを試したとき,何度やってもインストールに失敗する状態に陥ってしまいました。

実はクリーンインストール前にWindows Updateの一部のプログラムが何度やっても更新失敗になる不具合があり(これもOnekey Theatreが怪しい),何度も更新してはWindowsの再起動をしていたのですが……

アップデートの失敗に伴う再起動としても異常に再起動に時間が掛かる
絶対おかしい。

今までなかった「青旗マークが消えた後数回液晶のバックライトが点滅し完全な黒画面になる」という謎の挙動をしていました。

で,クリーンインストールしようとしたらこれも失敗するので,おそらくメモリの不具合だろうとあたりを付けました。

4GBのTranscend製(Micronチップ)とG560標準装備だった2GBのSamsung製の計6GBで運用していたので,Samsungメモリを外して再起動してみたところ,

Windows 10インストール成功!
起動時間も元通り!


ひと通り落ち着いてじっくり検証してみたところ,Samsungメモリを挿していたスロットがおかしいようで,メモリテストでエラーは出ないものの起動が激遅になります。

仕方ないのでG560はメモリスロット1基仕様として運用です。
DDR3メモリは8GBモジュールが存在するので,いざとなれば十分容量は確保できます。
余ったメモリで5GBとか6GBとかにできると便利ではありますが,妥協できるラインです。

メモリテストでエラーにならず,起動自体はするのにこんな不具合も起きるんだなーと今更ながら初メモリ不具合にときめいております。
はじめは速度も容量もメーカーも違うメモリを一緒にしていたら相性問題でも起きたのかと思いましたが……

メモリは壊れても交換すれば済みますが,スロットはなかなか直せませんから,不用なメモリ抜き差しは出来る限りしないように気をつけようと思います。




以上,簡単なG560とWindows 10のレポートでした。

2 件のコメント:

  1. G560のメモリースロットの情報ありがとうございます。
    当方はSSD換装のWindows7環境ですが、起動(Desktop表示までの時間)が早くなりました。

    環境1 工場出荷状態
       SLOT1/標準の三星2G SLOT2/Trancend4G
       起動時間は4分以上で、アクセスランプ点灯しっぱなし。

    環境2 製品版のWin7をクリーンインストール
       SLOT1/標準の三星2G SLOT2/Trancend4G
       起動時間は約2分

    環境3 環境2の状態から、メモリー1を外す。
       SLOT1/無し SLOT2/Trancend4G
       起動時間は約10秒

    返信削除
    返信
    1. Samsung 2GB+Trancend 4GBと、偶然にも私と同様のメモリ構成ですね
      とは言え、組み合わせによってスロット不良が起こるとは考えにくいですが……

      もとが安かった機種なので、そろそろこういう不具合が起きるのも仕方ないのかもしれませんが、どうもSLOT1の方が壊れやすいようですね。

      削除

電力会社の切り替えをしました!(中国電力管内)

 久しぶりに電力会社を切り替えました。 今までの流れ ↓ 中国電力→大東建託→@niftyでんき→エルピオでんき→シン・エナジー(NEW!) ということで,今回は シン・エナジー の契約です。 エルピオは使えば使うほど割安になる(正確に言うとたくさん使っても割高にならない)タイプ...